re = /([0-9])\s+([0-9])\s+([A-Za-z0-9- ]+?)\s{2,}([A-Za-z0-9- ]+?)\s+([A-Za-z0-9]+)/m
str = '1 2 CCS-7354 Series Supervisor Module 7354-SPP JD546546527'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end