using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<div[^>]*>(?:(?!</div>)[\s\S])*searched string(?:(?!</div)[\s\S])*</div>";
string input = @"<div class=""testclass"">random example text</div>
<div id=""testid"">foo bar foo searched string foo bar</div>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}