$re = '~<div[^>]*>(?:(?!</div>)[\s\S])*searched string(?:(?!</div)[\s\S])*</div>~m';
$str = '<div class="testclass">random example text</div>
<div id="testid">foo bar foo searched string foo bar</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);