const regex = new RegExp('\\[\\)>\\u001E01\\u001D[0-9]{2}[0-9]{9}\\u001D[0-9]{3}\\u001D[0-9]{3}\\u001D.+', 'gm')
const str = `[)>01961234567898401231Z00ETC
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}