re = /\[\)>\u001E01\u001D[0-9]{2}[0-9]{9}\u001D[0-9]{3}\u001D[0-9]{3}\u001D.+/m
str = '[)>01961234567898401231Z00ETC
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end