package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)aab+`)
var str = `aaabcc
aaaabcc
aabbbbc
aacc
a`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}