$re = '/aab+/m';
$str = 'aaabcc
aaaabcc
aabbbbc
aacc
a';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);