$re = '/(?<ext>\..{3,})/m';
$str = 'file_record_transcript.pdf
file_07241999.pdf
testfile_fake.pdf.tmp';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);