re = /(?<ext>\..{3,})/m
str = 'file_record_transcript.pdf
file_07241999.pdf
testfile_fake.pdf.tmp'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end