const regex = /(?=.*\d)(?=.*[a-z])(?=.*[A-Z]).{7,12}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=.*\\d)(?=.*[a-z])(?=.*[A-Z]).{7,12}', '')
const str = `flOwer123`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}