$re = '/(?=.*\d)(?=.*[a-z])(?=.*[A-Z]).{7,12}/';
$str = 'flOwer123';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);