package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^\p{Han}]+`)
var str = `t你好
這是中國
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}