package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\b{1}не)|(^не)`)
var str = `не надо мне
это не то не`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}