$re = '/(\b{1}не)|(^не)/m';
$str = 'не надо мне
это не то не';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);