package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/\*[.\t\r\f\v \S]*\*\/|^[\t\r\f\v ]*\/\/.*`)
var str = `/*
cool
*/
// Yess
// It works
but not on an // inline comment`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}