$re = '/\/\*[.\t\r\f\v \S]*\*\/|^[\t\r\f\v ]*\/\/.*/m';
$str = '/*
cool
*/
// Yess
// It works
but not on an // inline comment';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);