$re = '/((\d)?\*?((?:n\d+)(?:\*n\d+)*))/m';
$str = '6*n101110111*n111111111 + 3*n101111101 + 6*n101111111 + n111111111';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);