// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)((\d)?\*?((?:n\d+)(?:\*n\d+)*))").unwrap();
let string = "6*n101110111*n111111111 + 3*n101111101 + 6*n101111111 + n111111111";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}