import re
regex = re.compile(r"(?=_{20,}|From:|On\s\w{3},\s\w{3}\s\d{1,2},\s\d{4}\sat\s\d{1,2}:\d{2})", flags=re.IGNORECASE)
test_str = ("Great thank you\n"
"________________________________\n"
"From: Blake <blake@foursocial.uk>\n"
"Sent: Saturday, August 31, 2024 9:46:12 AM\n"
"To: blake hoang <bjh2004@hotmail.co.uk>\n"
"Subject: Re: Ignition. Campaign\n\n"
"Thanks , yes we can do it\n"
"---\n"
"Blake Junior\n"
"Managing Director | Foursocial.\n"
"blake@foursocial.uk<mailto:blake@foursocial.uk>\n"
"Submission Links<https://linktr.ee/foursocial1>\n"
"[https://ci3.googleusercontent.com/mail-sig/AIorK4yeSFbHM5imdVzOjDTr7LwNvS9gqpyQ83uajylr7mDBuRn5ymG1jlev6Zz8vvgQMzDLAYjFLcR7LVLu]\n\n\n"
"On Sat, Aug 31, 2024 at 9:45 AM blake hoang <bjh2004@hotmail.co.uk<mailto:bjh2004@hotmail.co.uk>> wrote:\n"
"Hey there let me know the fee")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")