import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
    public static void main(String[] args) {
        final String regex = "^([a-zA-Z0-9]*[a-zA-Z]+[a-zA-Z0-9]*\\.[a-zA-Z0-9]*\\.[a-zA-Z0-9]*|[a-zA-Z0-9]*\\.[a-zA-Z0-9]*[a-zA-Z]+[a-zA-Z0-9]*\\.[a-zA-Z0-9]*|[a-zA-Z0-9]*\\.[a-zA-Z0-9]*\\.[a-zA-Z0-9]*[a-zA-Z]+[a-zA-Z0-9]*)(~|\\-|\\+){0,1}[a-zA-Z0-9]+$";
        final String string = "//good\n"
	 + "rc0.05.00\n"
	 + "0rc.05.00\n"
	 + "0.rc05.00\n"
	 + "0.05rc.00\n"
	 + "rc0.rc05.00\n"
	 + "rc0.05rc.00\n"
	 + "rc0rc.rc05.00\n"
	 + "rc0.rc05rc.00\n"
	 + "rc0.rc05rc.rc00\n"
	 + "rc0.rc05rc.00rc\n\n"
	 + "0.0.0sr1+asdf\n"
	 + "0.0.0sr1\n"
	 + "errhand.LSD.asdf+dfsg\n\n\n"
	 + "//bad\n"
	 + "1.1\n"
	 + "1.1.1\n"
	 + "1.00.00\n"
	 + "v1c.1.\n"
	 + "1.v1c.\n"
	 + "1.01.01~sdgf\n"
	 + "1.v1c.asdf-sadf+asdf\n"
	 + "~1c.1c.0\n"
	 + "1c.1~c.0";
        
        final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
        final Matcher matcher = pattern.matcher(string);
        
        while (matcher.find()) {
            System.out.println("Full match: " + matcher.group(0));
            
            for (int i = 1; i <= matcher.groupCount(); i++) {
                System.out.println("Group " + i + ": " + matcher.group(i));
            }
        }
    }
}