import re
regex = re.compile(r"^([a-zA-Z0-9]*[a-zA-Z]+[a-zA-Z0-9]*\.[a-zA-Z0-9]*\.[a-zA-Z0-9]*|[a-zA-Z0-9]*\.[a-zA-Z0-9]*[a-zA-Z]+[a-zA-Z0-9]*\.[a-zA-Z0-9]*|[a-zA-Z0-9]*\.[a-zA-Z0-9]*\.[a-zA-Z0-9]*[a-zA-Z]+[a-zA-Z0-9]*)(~|\-|\+){0,1}[a-zA-Z0-9]+$", flags=re.MULTILINE)
test_str = ("//good\n"
"rc0.05.00\n"
"0rc.05.00\n"
"0.rc05.00\n"
"0.05rc.00\n"
"rc0.rc05.00\n"
"rc0.05rc.00\n"
"rc0rc.rc05.00\n"
"rc0.rc05rc.00\n"
"rc0.rc05rc.rc00\n"
"rc0.rc05rc.00rc\n\n"
"0.0.0sr1+asdf\n"
"0.0.0sr1\n"
"errhand.LSD.asdf+dfsg\n\n\n"
"//bad\n"
"1.1\n"
"1.1.1\n"
"1.00.00\n"
"v1c.1.\n"
"1.v1c.\n"
"1.01.01~sdgf\n"
"1.v1c.asdf-sadf+asdf\n"
"~1c.1c.0\n"
"1c.1~c.0")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")