package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[+-]?(\d+|\d+\,\d+)$`)
var str = `25,5
-25,05
+2
5
25,00000007
25`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}