$re = '/^[+-]?(\d+|\d+\,\d+)$/m';
$str = '25,5
-25,05
+2
5
25,00000007
25';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);