import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[LNSE] (.*(?:\\n(?![LNSE] ).*)?)";
final String string = "L 065 00 24329 12313 244.0.15.55 252.9.11.90 02/25 08:05 00:00:44 0000 0000 \n"
+ " \n"
+ "N 066 00 23442 T000185 262.1.00.09 02/25 08:05 00:00:02 A 16630\n"
+ "& 0000 0000 \n"
+ "S 067 00 00984 T000134 02/25 08:06 00:00:02 A 61445\n"
+ "& 0000 0000 \n"
+ "S 068 00 T000002 29536 02/25 08:05 00:00:36 \n"
+ "& 0000 0000 1234567890XXXXXX \n"
+ "E 069 00 T000002 T000185 02/25 08:06 00:00:00 \n"
+ "& 0000 0000 1234567890XXXXXX\n"
+ "L 065 00 24329 12313 244.0.15.55 252.9.11.90 02/25 08:05 00:00:44 0000 0000 ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}