import re
regex = re.compile(r"^[LNSE] (.*(?:\n(?![LNSE] ).*)?)", flags=re.MULTILINE)
test_str = ("L 065 00 24329 12313 244.0.15.55 252.9.11.90 02/25 08:05 00:00:44 0000 0000 \n"
" \n"
"N 066 00 23442 T000185 262.1.00.09 02/25 08:05 00:00:02 A 16630\n"
"& 0000 0000 \n"
"S 067 00 00984 T000134 02/25 08:06 00:00:02 A 61445\n"
"& 0000 0000 \n"
"S 068 00 T000002 29536 02/25 08:05 00:00:36 \n"
"& 0000 0000 1234567890XXXXXX \n"
"E 069 00 T000002 T000185 02/25 08:06 00:00:00 \n"
"& 0000 0000 1234567890XXXXXX\n"
"L 065 00 24329 12313 244.0.15.55 252.9.11.90 02/25 08:05 00:00:44 0000 0000 ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")