#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:.(?=.*\n(\1?+.)))*?(?=Size)(?:\w\B(?=.*\n\1?+(\2?+\D)))*+.*\n\1?+\2?+(?<![\d.])([\d.]+)"
Local $sString = "Property Size" & @CRLF & _
"Jerusale811.00" & @CRLF & _
"" & @CRLF & _
"Property Size" & @CRLF & _
"Jerusalem811.00" & @CRLF & _
"" & @CRLF & _
"Property Size" & @CRLF & _
"Jerusalem 811.00" & @CRLF & _
"" & @CRLF & _
"Property Size" & @CRLF & _
"Jerusalem 811.00" & @CRLF & _
"" & @CRLF & _
"Property Size" & @CRLF & _
"Jerusalem 811.00" & @CRLF & _
"" & @CRLF & _
"Property Size" & @CRLF & _
"Jerusalem 811.00" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")