using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:.(?=.*\n(\1?+.)))*?(?=Size)(?:\w\B(?=.*\n\1?+(\2?+\D)))*+.*\n\1?+\2?+(?<![\d.])([\d.]+)";
string input = @"Property Size
Jerusale811.00
Property Size
Jerusalem811.00
Property Size
Jerusalem 811.00
Property Size
Jerusalem 811.00
Property Size
Jerusalem 811.00
Property Size
Jerusalem 811.00
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}