package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\h*('+.+?'+)\h*|\h*([^;].+?)\h*;`)
var str = `тыры-пыры; тро-лоло, ляж; гыыы; 'safsdfsadfsad;fsadfsf';;`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}