$re = '/\h*(\'+.+?\'+)\h*|\h*([^;].+?)\h*;/';
$str = 'тыры-пыры; тро-лоло, ляж; гыыы; \'safsdfsadfsad;fsadfsf\';;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);