const regex = new RegExp('\\G(\\d+),(?=\\d+(?:,\\d+)*(?:\\.\\d+)?$)', 'gm')
const str = `11,340,567.65`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);