const regex = new RegExp('(?<=(?<![.\\s])[a-zA-Z])\\.', 'gm')
const str = `This is the U.A. we have r.a.d. golden 13.56 date. a better date 34. was there.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}