re = /(?<=(?<![.\s])[a-zA-Z])\./m
str = 'This is the U.A. we have r.a.d. golden 13.56 date. a better date 34. was there.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end