#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sU)class="rasschetSredstv".*<td>.*?href="(?P<URL>.*)".*(?P<DATE>15.03.\d\d\d\d).*</td>"
Local $sString = "<div class="rasschetSredstv">" & @CRLF & _
"<table class="tab td_tac" border="0" cellpadding="10" cellspacing="0">" & @CRLF & _
" <tbody><tr>" & @CRLF & _
" <th width="17%">Январь</th>" & @CRLF & _
" <th width="17%">Февраль</th>" & @CRLF & _
" <th width="17%">Март</th>" & @CRLF & _
" <th width="17%">Апрель</th>" & @CRLF & _
" <th width="17%">Май</th>" & @CRLF & _
" <th width="17%">Июнь</th>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td>" & @CRLF & _
" " & @CRLF & _
" <a target="_blanc" href="/upload/iblock/2da/otchet_ss_310117.pdf">Скачать</a><br>" & @CRLF & _
" pdf(201 кБ)<br> (14.02.2017 12:44:00) </td>" & @CRLF & _
" <td>" & @CRLF & _
" " & @CRLF & _
" <a target="_blanc" href="/upload/iblock/aa8/otchet_rss_na_sayt.pdf">Скачать</a><br>" & @CRLF & _
" pdf(196 кБ)<br> (15.03.2017 18:49:00) </td>" & @CRLF & _
" <td>" & @CRLF & _
" " & @CRLF & _
" <a target="_blanc" href="/upload/iblock/71e/raschet_ss_na_sayt.pdf">Скачать</a><br>" & @CRLF & _
" pdf(197 кБ)<br> (14.04.2017 18:23:00) </td>" & @CRLF & _
" <td>" & @CRLF & _
" " & @CRLF & _
" ----" & @CRLF & _
" </td>" & @CRLF & _
" <td>" & @CRLF & _
" " & @CRLF & _
" ----" & @CRLF & _
" </td>" & @CRLF & _
" <td>" & @CRLF & _
" " & @CRLF & _
" ----" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <th>Июль</th>" & @CRLF & _
" <th>Август</th>" & @CRLF & _
" <th>Сентябрь</th>" & @CRLF & _
" <th>Октябрь</th>" & @CRLF & _
" <th>Ноябрь</th>" & @CRLF & _
" <th>Декабрь</th>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td>" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" ----" & @CRLF & _
" </td>" & @CRLF & _
" <td>" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" ----" & @CRLF & _
" </td>" & @CRLF & _
" <td>" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" ----" & @CRLF & _
" </td>" & @CRLF & _
" <td>" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" ----" & @CRLF & _
" </td>" & @CRLF & _
" <td>" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" ----" & @CRLF & _
" </td>" & @CRLF & _
" <td>" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" ----" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
"</tbody></table>" & @CRLF & _
"</div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")