# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"class=\"rasschetSredstv\".*<td>.*?href=\"(?P<URL>.*)\".*(?P<DATE>15.03.\d\d\d\d).*</td>"
test_str = ("<div class=\"rasschetSredstv\">\n"
"<table class=\"tab td_tac\" border=\"0\" cellpadding=\"10\" cellspacing=\"0\">\n"
" <tbody><tr>\n"
" <th width=\"17%\">Январь</th>\n"
" <th width=\"17%\">Февраль</th>\n"
" <th width=\"17%\">Март</th>\n"
" <th width=\"17%\">Апрель</th>\n"
" <th width=\"17%\">Май</th>\n"
" <th width=\"17%\">Июнь</th>\n"
" </tr>\n"
" <tr>\n"
" <td>\n"
" \n"
" <a target=\"_blanc\" href=\"/upload/iblock/2da/otchet_ss_310117.pdf\">Скачать</a><br>\n"
" pdf(201 кБ)<br> (14.02.2017 12:44:00) </td>\n"
" <td>\n"
" \n"
" <a target=\"_blanc\" href=\"/upload/iblock/aa8/otchet_rss_na_sayt.pdf\">Скачать</a><br>\n"
" pdf(196 кБ)<br> (15.03.2017 18:49:00) </td>\n"
" <td>\n"
" \n"
" <a target=\"_blanc\" href=\"/upload/iblock/71e/raschet_ss_na_sayt.pdf\">Скачать</a><br>\n"
" pdf(197 кБ)<br> (14.04.2017 18:23:00) </td>\n"
" <td>\n"
" \n"
" ----\n"
" </td>\n"
" <td>\n"
" \n"
" ----\n"
" </td>\n"
" <td>\n"
" \n"
" ----\n"
" </td>\n"
" </tr>\n"
" <tr>\n"
" <th>Июль</th>\n"
" <th>Август</th>\n"
" <th>Сентябрь</th>\n"
" <th>Октябрь</th>\n"
" <th>Ноябрь</th>\n"
" <th>Декабрь</th>\n"
" </tr>\n"
" <tr>\n"
" <td>\n"
" \n"
" \n"
" ----\n"
" </td>\n"
" <td>\n"
" \n"
" \n"
" ----\n"
" </td>\n"
" <td>\n"
" \n"
" \n"
" ----\n"
" </td>\n"
" <td>\n"
" \n"
" \n"
" ----\n"
" </td>\n"
" <td>\n"
" \n"
" \n"
" ----\n"
" </td>\n"
" <td>\n"
" \n"
" \n"
" ----\n"
" </td>\n"
" </tr>\n"
"</tbody></table>\n"
"</div>")
matches = re.search(regex, test_str, re.DOTALL)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.