$re = '/^(?:(?! PAGE)[A-Z0-9\s])+[A-Z](?: \d{4})?\b/m';
$str = 'FREE SOFT FOUNDATION V2 1989 PAGE 2
STALLMANWORKS 2000 1977;PAGE 2
THE GNU PAGE 3 1977';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);