package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:[A-Za-z]+ ){2}[A-Za-z]+`)
var str = `123 test bla foo
das adasdas adasd dsa`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}