$re = '/(?:[A-Za-z]+ ){2}[A-Za-z]+/';
$str = '123 test bla foo
das adasdas adasd dsa';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);