package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\w{1,2}-\d{1,4})+\w`)
var str = `D-1150A
D-1150B
D-1150C`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}