$re = '/(?<=\G(?!^)|to)./m';
$str = 'thisisstringtoreplace';
$subst = "*";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;