package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)shellies\/([^\/]*)\/`)
var str = `shellies/light/1g/shelly1-ABCDEF123456/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}