$re = '/shellies\/([^\/]*)\//m';
$str = 'shellies/light/1g/shelly1-ABCDEF123456/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);