using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b[AZQ]\d{10,14}(>\S+).*?(First Time : \d\d:\d\d[AP]M).*?\sAAABBB\b";
string input = @"qitjfjdjqkfjjf 1934848[*{*}*}*#*#*#[#*
]*,qgvv]*?£[£?£,£~'_!~£[££<£<'<'?£]!<!<
['~£,'}'<',!']'',',<€~Z1234566789>Z12345667890
1'fncnr'qmtjcsmsj194&($.!:!
,$/&15?'?'(''(('(''158,$3,!!1
1'('(',';?1!( First Time : 10:10PM
1&4$,!;($qmfjccn1'fkfkckcqtngcnnq
AAABBB : ,$2$$(&158((&&,&,&;&(&&((&
qitjfjdjqkfjjf 1934848[*{*}*}*#*#*#[#*
]*,€]*?£[£?£,£~'_!~£[££<£<'<'?£]!<!<
['~£,'}'<',!']'',',<€~A1234566789>A1234566789123
1'fncnr'qmtjcsmsj194&($.!:!
,$/&15?'?'(''(('(''158,$3,!!1
1'('(',';?1!( First Time : 10:10PM
1&4$,!;($qmfjccn1'fkfkckcqtngcnnq
AAABBB : :&;&;&(&;'1(&?&,&,&1&(&(,
$2$$(&158((&&,&,&;&(&&((&;&;&;&;&
qitjfjdjqkfjjf 1934848[*{*}*}*#*#*#[#*
]*,€]*?£[£?£,£~'_!~£[££<£<'<'?£]!<!<
['~£,'}'<',!']'',',cjejfnfn<€~Q1234566789>Q123456678912
1'fncnr'qmtjcsmsj194&($.!:!
,$/&15?'?'(''(('(''158,$3,!!1
1'('(',';?1!( First Time : 10:10PM
1&4$,!;($qmfjccn1'fkfkckcqtngcnnq
dbxbxne AAABBB : ,$2$$(&158((&&,&,&;&(&&((&";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}