import re
regex = re.compile(r"\b[AZQ]\d{10,14}(>\S+).*?(First Time : \d\d:\d\d[AP]M).*?\sAAABBB\b", flags=re.MULTILINE | re.DOTALL)
test_str = ("qitjfjdjqkfjjf 1934848[*{*}*}*#*#*#[#*\n"
"]*,qgvv]*?£[£?£,£~'_!~£[££<£<'<'?£]!<!<\n"
"['~£,'}'<',!']'',',<€~Z1234566789>Z12345667890\n"
"1'fncnr'qmtjcsmsj194&($.!:!\n"
",$/&15?'?'(''(('(''158,$3,!!1\n"
"1'('(',';?1!( First Time : 10:10PM\n"
"1&4$,!;($qmfjccn1'fkfkckcqtngcnnq\n"
"AAABBB : ,$2$$(&158((&&,&,&;&(&&((&\n\n"
"qitjfjdjqkfjjf 1934848[*{*}*}*#*#*#[#*\n"
"]*,€]*?£[£?£,£~'_!~£[££<£<'<'?£]!<!<\n"
"['~£,'}'<',!']'',',<€~A1234566789>A1234566789123\n"
"1'fncnr'qmtjcsmsj194&($.!:!\n"
",$/&15?'?'(''(('(''158,$3,!!1\n"
"1'('(',';?1!( First Time : 10:10PM\n"
"1&4$,!;($qmfjccn1'fkfkckcqtngcnnq\n"
"AAABBB : :&;&;&(&;'1(&?&,&,&1&(&(,\n"
"$2$$(&158((&&,&,&;&(&&((&;&;&;&;&\n\n\n"
"qitjfjdjqkfjjf 1934848[*{*}*}*#*#*#[#*\n"
"]*,€]*?£[£?£,£~'_!~£[££<£<'<'?£]!<!<\n"
"['~£,'}'<',!']'',',cjejfnfn<€~Q1234566789>Q123456678912\n"
"1'fncnr'qmtjcsmsj194&($.!:!\n"
",$/&15?'?'(''(('(''158,$3,!!1\n"
"1'('(',';?1!( First Time : 10:10PM\n"
"1&4$,!;($qmfjccn1'fkfkckcqtngcnnq\n"
"dbxbxne AAABBB : ,$2$$(&158((&&,&,&;&(&&((&")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")