$re = '/<img([\w\W]+?)\/?>/mi';
$str = '<img src="imagem1">
texto
<img src="imagem2.jpg">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);