const regex = /(\b(https?|ftp|file):\/\/)?[-A-Za-z0-9+&@#\/%?=~_|!:,.;]+[-A-Za-z0-9+&@#\/%=~_|]/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\b(https?|ftp|file):\\\/\\\/)?[-A-Za-z0-9+&@#\\\/%?=~_|!:,.;]+[-A-Za-z0-9+&@#\\\/%=~_|]', 'i')
const str = `https://www.hwk-muenchen.de/artikel/exporteinsteiger-74,4028,7642.html`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}