re = /(\b(https?|ftp|file):\/\/)?[-A-Za-z0-9+&@#\/%?=~_|!:,.;]+[-A-Za-z0-9+&@#\/%=~_|]/i
str = 'https://www.hwk-muenchen.de/artikel/exporteinsteiger-74,4028,7642.html'
# Print the match result
str.match(re) do |match|
puts match.to_s
end