using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"@(?!author|Autowired|Override|param|SuppressWarnings).*";
string input = @"@author
@Autowired
@Override
@param
@SuppressWarnings
@NotThisOne
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}