re = /@(?!author|Autowired|Override|param|SuppressWarnings).*/
str = '@author
@Autowired
@Override
@param
@SuppressWarnings
@NotThisOne
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end