import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*\\d+\\s+Secs\\s*\\(\\s*(\\d+(?:\\.\\d+)?%)\\)\\s+\\d+\\s+Secs\\s+\\(\\s+(\\d+(?:\\.\\d+)?%)\\)\\s+\\d+\\s+Secs\\s+\\(\\s+(\\d+(?:\\.\\d+)?%)\\)$";
final String string = "5 Secs ( 22.3463%) 60 Secs ( 25.677%) 300 Secs ( 21.3522%)\n"
+ " 5 Secs ( 13.6713%) 60 Secs ( 15.3520%) 300 Secs ( 15.9640%)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}