const regex = /^\s*\d+\s+Secs\s*\(\s*(\d+(?:\.\d+)?%)\)\s+\d+\s+Secs\s+\(\s+(\d+(?:\.\d+)?%)\)\s+\d+\s+Secs\s+\(\s+(\d+(?:\.\d+)?%)\)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*\\d+\\s+Secs\\s*\\(\\s*(\\d+(?:\\.\\d+)?%)\\)\\s+\\d+\\s+Secs\\s+\\(\\s+(\\d+(?:\\.\\d+)?%)\\)\\s+\\d+\\s+Secs\\s+\\(\\s+(\\d+(?:\\.\\d+)?%)\\)$', 'gm')
const str = `5 Secs ( 22.3463%) 60 Secs ( 25.677%) 300 Secs ( 21.3522%)
5 Secs ( 13.6713%) 60 Secs ( 15.3520%) 300 Secs ( 15.9640%)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}